Client Invoice Designer CIUiCk reference For more information, see Help > Contents > Invoice formats > Client Invoice Designer.

Follow the instructions in this quick reference for some basic changes you can ]
make using the Client Invoice Designer. Before you begin

Before getting started, be sure to review all the

Important! The Client Invoice Designer is Microsoft Reporting Services with information available to you in:

Ajera data preloaded. In most cases, you need to have some knowledge of

Microsoft Reporting Services to accomplish your goals. Ajera Help > Contents > Invoice formats > Client

Invoice Designer.

As you explore and experiment, if you want to discard your changes and start
over by returning to the standard invoice format, close the Client Invoice
Designer, and click the Standard button on the Invoice Format window.

In this quick reference

The workspace

Understanding the types of fields
Changing a font

Adding text on the invoice

Adding information using a parameter
Adding information using a report dataset
Adding a custom field

Adding a row
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The workspace

Where to work What's in the workspace
The Layout tab is your workbench for changing the text and other The workspace contains only the data from the Ajera database
information that appears on the invoice. that is related to an invoice.

The Preview tab shows you the result of your changes on an invoice.
Empty workspace

Go between the Layout and Preview tab as you make changes. If the workspace is empty when you open it, click the Solution
Explorer icon. In the Solution Explorer window, select the
Reports folder > AjeraCustomlinvoiceFormat.rdl.

Solution

; Solution
Explorer icon

Explorer

Layout tab Preview tab window
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tables that represent parts of the invoice. =Parameters!gClientMailingLine1.Value ="Invoice number:” =Parameters!glt
H H H =Parameters!gClientMailingLine2 Value ="Date:” =Parameters!glr

Ta-bleS Contal_n ﬂe_lds that determlne What sParametersigClientMailingLine3.Value =iif{ParameterslglnvoiceStatus.Value=
prlnts on the invoice. =ParameterslgClienthlailingLine4.Value | ="Projec=UCase(IF(ParametersigProje
=Parameters!gClientMailingLines.Value e e

=ParameterslgClientiMailingLinef Value

When you click a field in a table, icons :
appear in the left gutter to identify each row || |-ParametersigHeaderText value <

m 13
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to highlight all the items in the table.
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Understanding the types of fields

AjeraCustomInvoic...mat.rdl [Design]* | | .
Actual text that prints

Data [ Layout |[Z Preview on the invoice either ...
I
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Fields beginning with ...appears in ...or simply

i are created =ParameterslgCompanyiiailingLine? BTN E1E 6 appears without
using parameters. =ParameterslgCompanyhailingLine3 guotes, equal
=ParametersioCompanyidailingLined = signs, or any
=ParameterslogCompanyhailinglines vValu special characters.
=ParametersigCompanyiailingLines Value

You can add parameter
fields, such as project ID

and client name, to any
table.
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Fields beginning with |\ e e
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These fields hold data =FieldsteActivityTypeDescription.\alue

such as employee, . . - -
vendor, rates, and =Flrslf FlaldstteBiilingd ctivib TynaTaxt I/ alue)

amounts.

Hours
LInits
nits

The color of fields in the
Time & Expense table
=FieldslteDetailGroup1 Description < indicates the activity type:

=FieldslteDetailGroup1 Description Value e = Eer
=FieldslteDetailGroup1 Description.Yalue Green = consultant code.Mofe | =cor
=i I Red = expense
ITe in a field name indicates that

it is a field from the Time and

You can add a field from
the Reports Dataset
window only to its
corresponding table in the
Layout tab.

=code.Mofe|=cor

Expense part of the invoice.

Hover over a field to display more
details about it. 3
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Changing a font

1. Click a field where you want to change the font.

To change more than one field, click a field and drag over the additional fields in
the table. You can select only multiple fields within a table. To change the font for
an entire invoice, repeat these instructions for each table in the Layout tab.

2. Change the font using the Format menu, toolbar, or Properties window.

Note: If you use the Properties window, you can only change more than one field
at a time if the original settings for all the fields are the same.

3. Click the Preview tab to be sure the text you changed fits properly on the
invoice. Resize the field or surrounding fields, as needed.

Use the
Properties

Use the Format window.

menu. Use the toolbar.
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Adding text on the invoice

For more information, see Help > Contents > Invoice formats > Client Invoice Designer.

Follow these instructions to add text to the invoice or change text AjeraCustom Invoic...mat.rdl [Design]* Text typed in the cell

clients or a different heading.

1.

that appears on it. For example, you may want to add a note to - -
PP ey y L7 Data @ Layout || Preview

Either click the field you want to change, or simply click an |:|| a oo

empty field where you want to add text.

You can also copy an existing field by clicking it and then
copying and pasting it where you want it to appear on the

invoice. Delete the text that is in it.

Type the text, or if you want to include text and data in the

same field, do the following:

e Right-click, and click Expression.

e Inthe text box at the top of the Expression window, type
the text you want, prefaced by an equal sign and

enclosed in quotes. For example, type:
="Project Manager:"+GProjectManagerName
Click the Preview tab to see your changes.

1T+ vz
=Flgldsiad TransactionNate
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1

Phase Summany
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Labor =code MoZeroll | =code .Nj
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||_.||_.||_.||

Text entered as
an expression
for the field

arametersigir

invtdailinglinet Malue
invtdailingline2 . Yalue
iyailinoLine3 Yalue
iyailinoLined Yalue
iyiailinoLines Yalue
ihailinoLined Value

="lrwoice number” =Parameters!glrmvoiceh
="[ate™ =FirstiField=larinvoicel
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Adding information using a parameter

Use this method to add a parameter field that contains
information such as a client name, project ID, and so on.

To add detailed information, such as an employee, vendor,
billed rate, or amounts, follow the instructions for Adding
information using a report dataset.

1. Click an empty field where you want to add the new [ [
field.
=Parameters!gInvoiceCutoffDate.Value s
If there is no empty field in the area where you want to }.
add the new field, follow the instructions for Adding a e e
L]
row. %
..
2. Right-click the field, and select Expression. The Edit ‘e | <
. . « ol y
Expression window appears. -
) '. l Undo ] l Paste
3. Inthe box on the left, double-click Parameters. °
- Constants Vﬁ\ gClientBillingContact i
4. Find the field you want in the list at the right, and ~Globals ‘. et ot Phone
double-click it. Parameterse o, '.. gClientBillingContactEmail
Fields (AxRDI_Invmcé_Tlm%AndExp ° gToday
. .. . ° ° glnvoiceKey
5. The field definition appears in the box at the top of the - Datasets ‘esl, ° glnvoiceStatus
. [t Operators Ce, . ° glnvoiceStatusDescription
WlndOW. __ Commen Functicns ®e oo .0 glnvoiceGroupMotes
e, ° ®ly| glnvoiceNumber
6. Click OK. e, . glnvoiceDate
A
glnvoiceSubTotal
glnvoiceAdjustment H
glnvoiceAdjustmentMotes
glnvoiceSalesTax
glnvoiceTET otal
glnvoiceFeeTotal
glnvoiceTotal i
] 1 3 "41| 8 m Hontied | v
ok | [ e ] [ Help
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Adding information using a report dataset

This method works well if:

e You need to add detailed data to the invoice, such " 3 it bpresion o
as the employee, vendor, billed rate, or amounts. - A
e You can readily find the field in the dataset and can
match it to the correct table in the Layout tab.
Otherwise, follow the instructions for Adding information ‘ — ]i — ]
using a parameter.
. . . L obals isGrouplKey
1. Click an empty field where you want to add the new field. R Groupt e
Fields (AxRDLInvoices InvoiceSumn) isGroupl Description
If there is no empty field in the area where you want to F= 0 Uy Bowm D /_ P :igizﬂﬁgg":{"m
. . . . erators isGroup2Order
add the new field, follow the instructions for Adding a F-2 9 Commn Functions e
row. [/ i e o i |G e e e B
- . B ol S
Important! Report datasets contain fields from the Ajera L it
database organized into folders that match different £ / PhasclovaiiDe ipteseDesrption EERRRREE RN R R
parts of the invoice. preseLovase] |- X i | [rmmesnmna
PhaseLevel5ID Rbedl el e
Each table in the Layout tab can include fields from only Phoselaveliil S—r————————
one report dataset. To determine the dataset, right-click oty - -
|n the f|e|d, and Se|eCt EXpreSSIonS PhaseLevel6ID . ="Invoice subtotal” =Parametersk
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) Bfuingsmupomﬂ s | | | ‘ ‘ ‘
2. In the Report Datasets window, expand the folder that osepmacetet W m SiTSummaryHeading Vaius
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H - H . . ; e 1=l i li = ljg =t i -: i 1
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Adding a custom field

Follow these instructions to add a custom field to your invoice.

For more information about custom fields, from the Contents in The expression CHsie el

Help, select Custom fields. must always ] _ expression
i . begin with = Title for the field (definition)
1. In Company > Custom fields, be sure that the Available

for custom invoice formats check box is selected for
the custom field you want to add to the invoice.

2. Inthe Client Invoice Designer, click an empty field where v
you want to add the custom field.

Right-click the field, and select Expression.
4. Click Fields in the box on the left.

Scroll through the list of fields at the right of the window
until you find the custom field you want to add, and click
it. Custom fields begin with cf.

Undo ] l Paste

The expression for the field you selected appears in the
area at the top of the window. Constants

telnvoiceContractLaborAmount -
telnvoiceContractExpenseAmount
telnvoiceContractConsultantAmoun
telnvoiceSpentAmount
telnvoiceSpentLaborAmount
telnvoiceSpentExpenseAmount

o P telnvoiceSpentConsultantAmount

i [ ] L
[#- Operators °e stelnvoiceRemainingAmount

"P.O. Number" .. Common Functions Ce, . felnvoiceRemaininglaborAmount
i . i A i ®q telwoiceRemainingExpenseAmount
To put the title after the field on the invoice, type the title e telfyoiceRemainingConsultantAmot
. H : . telnveiceBilledAmount

after the field expression and put the + before it. ) telmvtceBilledLaborAmount
. °e telnvoiceBilledExpenseAmount
7. Click OK. ®e ° telnvoiceBilledConsultantAmount
° telnvoiceBbledHours

®e teIm.roiceBilk.dExpenseUnits
" telnvoiceBilledConsultantUnits E|

cfActivityP OMumber I

4 LU} L3 4 n L3

6. If you want to display a title for the field on the invoice,
type it in area at the top of the window using the syntax
in this example:

Parameters
Fields (AxRDLInvoices_TimeAndExp
-~ Datasets ®e °
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Adding arow

Follow these instructions when you want to add a row. You can
then add fields and text to that row, as needed.

1. Click a field in the row above or below where you want to
add the new row.

2. Right-click the icon in the gutter, and select Insert Row
Above or Insert Row Below.

3. Add fields and text to the row, following the instructions
in this quick reference, as needed.

Icons appear in

the left gutter t% SRR T e e
when you click a =Farameters!dHeaderTeﬁ.Vélue
cell in a table. | | ' |I
[ |=Fields!teActivityTypeDescription.Value
F =FirstFieldsiteBilling Activity Tvpe Text Value)
Hours Rate |="Billed +13Hl
= InsertRow Above Units | Rate |="Billed” + CH
(| = InsertRowBelow | | ' ' ' Units Rate |="Billed” + CH
| 3 Delete Rows iDescrintion.‘-ﬁalﬁe .
r - Tabie Becder jDescrfnt!_n:un.'v'alu-_a _ _ _ .=|:fJ-j-3.r-J-:|Ze:m:cnde.N-:nZe:=Ffell-:_lsllleE?IIe_
NDescription Value =code MoZe =code MoZe =FieldshteBille
IE‘ Table Details b2Description Value | . . '=cade.NcZeE=|:ade.Nc?_e;=Fields!1eEliIIe.
[ 1= Table Footer - ' _ ="Sublotal" | =code.NoZe| [=Sum(Fieldst
U= foced Goonn ="Subtotal” =Sum(Fields't
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